Update: Kolab responsive skin

We’re pleased to announce an update for the Kolab Enterprise skin.

This update is a release of the new kolab Enterprise Responsive skin (known under the working title: Elastic). The release is available for for Kolab 16, on Red Hat Enterprise Linux 7, CentOS 7, Debian 8, Debian 9, Ubuntu 16.04 and Ubuntu 18.04,

The kolab-webclient meta package now provides (and requires) the new responsive kolab skin.

 

The skin can be selected from 'Settings -> Preferences -> User interface'. It is possible for an administrator to limit the list of skins available to end users (See below).

 

 

 

As the name indicates, the skin is responsive. It responds to the amount of screen space available on the host, and is hence equally useful on a large desktop monitor:

..and a mobile device:

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

As mentioned, an administrator can configure the skins available to end users by adding the following to the config file /etc/roundcubemail/config.inc.php:

$config['skins_allowed'] = array('kolab');

..and remove the ‘skin’ item from the ‘dont_override’ setting in the same file:

$config['dont_override'] = array();

If desired, change the default skin for those users who has no preference configured (in the same file):

$config['skin'] = 'kolab';

This last configuration eliminates the need for the ‘dont_override’ setting.

Update: pykolab 0.7.33

We’re pleased to announce an update for the pykolab packages, version 0.7.33.

This update is a bugfix release for Kolab Enterprise 14, available for Red Hat Enterprise Linux 6, Red Hat Enterprise Linux 7, CentOS 6, CentOS 7, Debian 7 and Debian 8.

The following issues are fixed;

  • T123747: An exception where making probelms when handling iTip CANCEL for a resource event. This has been fixed
  • Clean up of the use of duplicate names for functions and in-function scope variables when both are used in the same scope
  • T29104: Support unicode characters in event location field
  • Various other smaller inconveniences

Update: php-net-ldap3 1.0.7

We’re pleased to announce an update for the php-net-ldap3 packages, version 1.0.7.

This update is a bugfix and update release for Kolab Enterprise 14, available for Red Hat Enterprise Linux 6, CentOS 6, Red Hat Enterprise Linux 7, CentOS 7, Debian 7 and Debian 8.

The following issues are fixed and changed:

  • ‘find_domain()’ gave a wrong result when domain wasn’t found. This is fixed
  • Recursive deletion of domains failed. This is now fixed
  • LDAP_OPT_DEBUG_LEVEL option couldn’t be disabled. This is now fixed
  • ldapsearch commands was failing when configured host contained protocol schema prefix. This is now fixed